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Introduction 
 
ODBC vous permet de créer des rapports dans des programmes externes (tels que Microsoft Excel, 
Microsoft Access, ...) sur base des données reprises dans AbiFire5/AbiPlan5/AbiDispatch5. 
  

 

 
 

 
Il ne vous est par contre pas possible d’ajouter, de modifier ou de supprimer des 
données moyennant ces programmes externes. Ces actions sont uniquement 
possibles via AbiFire5. 
 

 
Mises à part les instructions d’installation, ce chapitre contient un mode d’emploi concis sur 
l’application d’AbiFire et de l’ODBC dans Microsoft Excel et Microsoft Access. Une remise à niveau, 
éventuelle, de vos connaissances de ces programmes est conseillée. 
 
 

1. Installation du driver ODBC 
 
Dans un premier temps, il est impératif pour garantir une liaison optimale entre un programme externe 
(tel que Microsoft Excel ou Access) et votre base de données AbiFire5, de s’assurer que le driver 
ODBC installé sur le PC est correct. 
 
Si votre service d’incendie utilise une Base de données Microsoft SQL Server, vous aurez besoin 
de la dernière version de SQL Server driver. Celle-ci est déjà installée si AbiFire5 ou AbiDispatch5 
est installé sur le PC. Si tel n’est pas le cas, vous devrez, dans un premier temps, installer la version 
la plus récente de Microsoft Data Access Components (MDAC) (voir plus loin). 
 
Si votre corps utilise une base de données Oracle, vous aurez besoin de la dernière version de 
Microsoft ODBC for Oracle driver. Par cela, vous devrez installer la version la plus récente de 
Microsoft Data Access Components (MDAC) (voir plus loin). 
 
Microsoft Data Access Components (MDAC) 2.8 ou supérieure. 

En fonction de la version du système d’exploitation, les versions suivantes de Microsoft Data Access 
Components (MDAC) doivent être installées : 

o Windows XP avec SP2 : contient déjà la dernière version de MDAC, aucune installation n’est 
exigée. 

o Windows XP avec ou sans SP1 : MDAC 2.8. 
o Windows 2000 : MDAC 2.8 SP1. 

 
Etape 1: Fermer tous les programmes ouverts. 
 
Etape 2: Placer le CD-ROM d’installation d’AbiFire5 dans un lecteur CD et ouvrir le répertoire   

"\Software requirements\Microsoft Data Access Components (MDAC)". 
 
Etape 3: Ouvrir le répertoire "MDAC 2.8 SP1" si le PC local dispose de Windows 2000. 

Ouvrir le répertoire "MDAC 2.8" si le PC local dispose de Windows XP avec ou sans SP1. 
 
Etape 4: Double clic sur MDAC_TYP.EXE et suivre les instructions. 
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2. Mise au point du module Système dans AbiFire5 
 
Pour pouvoir créer des rapports via un programme externe, un profil externe doit être créé dans le 
module système et lié à l’utilisateur. Un profil externe définit les données, de votre base de données 
AbiFire5, consultables via une application externe (telle que Microsoft Excel ou Access). Ce profil 
externe doit ensuite être attribué à un ou plusieurs utilisateurs. Les données peuvent donc être 
protégées des consultations indésirables. 
 

2.1. Créer un profil externe 
 
Dans le profil externe, vous déterminez par module l’accès aux tables : 
 

 
 

2.2. Attribution d’un profil externe à un utilisateur 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Pour plus d’informations concernant l’initialisation et l’utilisation des profils externes, veuillez vous 
référer à l’aide en ligne d’AbiFire5 ou au mode d’emploi “Partie 2 – Système”. 
 

 

 
 

 
Attention : pour les utilisateurs se loguant avec Windows Authentication, un login 
séparé est créé pour une utilisation externe dont le mot de passe est identique à l’ID. 
Modifier si souhaité le mot de passe qui peut être différent du mot de passe Windows. 
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3. Création d’un lien ODBC pour SQL Serveur 
 

 

Si AbiFire est déjà installé sur votre PC, vous pouvez utiliser le lien ODBC ABIDATA 
et aucun lien supplémentaire ODBC ne doit être créé. 

 
Ouvrir via le menu « Départ » (« Start ») l’écran de configuration (control panel), ouvrir Gestion du 
système (Administrative Tools) et démarrer le programme Gestion des sources de données (ODBC 
Data Sources). 
 
Choisir Système DSN – Cliquer sur le bouton Ajouter (Add) et sélectionner SQL Server-driver : 
 

 
 

 
 
Le nom du serveur est le nom du SQL Server instance. Vous retrouverez celui-ci dans la fenêtre 
lorsque vous vous loguez dans AbiFire ou dans le fichier ABIFIRE.INI (SERVER=XXXX). 
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Si vous n’avez aucun accès, veuillez vérifier si : 

 Login ID et le mot de passe sont corrects, 

 L’utilisateur est lié à un profil externe (ou se loguer ainsi) 
 

 
 
 
Passer ensuite à l’écran suivant et tester la source des données. 
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4. Créer lien ODBC pour Oracle 
 

 

 
 

AbiFire utilise une connexion directe avec Oracle. Pour une consultation via Excel, 
vous devez premièrement créer un lien ODBC via l’administrateur ODBC.  

 
Ouvrir via le menu démarrer, le panneau de configuration (Control Panel), ouvrir Gestion du Système 
(Administrative Tools) et démarrer le programme Gestion sources de données (ODBC Data Sources). 
 
Choisir System DSN, cliquer sur le bouton Ajouter (Add) et sélectionner "Microsoft ODBC pour Oracle" 
-driver : 
 

 
 

 
 
Le nom du serveur est le nom de la base de données Oracle. Vous retrouvez celui-ci dans la fenêtre 
pour se loguer dans AbiFire ou dans le fichier ABIFIRE.INI (SERVER=XXXX). 
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5. Microsoft Excel 2003/2007 et ODBC 
 

6.1 Afficher les données d’une table via l’assistant requête (wizard)  
 
Etape 1: Ouvrir Microsoft Excel 2003/2007 et créer une nouvelle feuille. 
 
Etape 2: Microsoft Excel 2003 

 
Sélectionner le menu Données > Import données externes > Créer une requête… 
Menu en anglais : Data > Import External Data > New Database Query… 
 

 
Microsoft Excel 2007 
 
Sélectionner le menu  Données > Import données externes > Créer une requête Data >  
Menu en anglais : Data > Import External Data > New Database Query… 
 

 
 
Etape 3: Sélectionner  <ABIDATA> et cliquer sur OK: 

 
 Cocher l’option 

Use the Query 
Wizard to 
create/edit 
queries. 
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Etape 4: Compléter l’ID et le mot de passe : 
 

 
 

 
Si vous n’avez pas d’accès, veuillez contrôler si : 

 L’ID et le mot de passe sont corrects. 

 L’utilisateur est relié à un profil externe. 

 Le lien ODBC travaille correctement. 

 SQL Server : contrôler si l’option « Use Trusted Connection » est décochée. 

 

Etape 5: Rechercher dans la liste de gauche la table dans laquelle se trouvent les données 
souhaitées et sélectionner les colonnes : 
 

 

 

Etape 6: Déterminer, si vous le souhaitez, le premier filtre des données que vous souhaitez afficher.  
 

 
 
Il vous sera toujours possible dans Excel d’établir des filtres sur les données et de les 
retravailler. 
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Etape 7: Déterminer si vous le souhaitez sur quelle base les données seront triées :  

  

 

 

 

 

 

 

 

 

 

 

 

Il vous sera toujours possible dans Excel de modifier le tri des données. 

 

Etape 8: Vous pouvez ensuite ouvrir la requête créée, la retravailler ensuite ou afficher les données : 

 
  

 

 

 

 

 

 

 

 

 

 

 

Etape 9: Si vous affichez les données dans Microsoft Excel, vous pouvez déterminer la feuille de 
travail où elle sera placée. Déterminer ensuite un autre emplacement et cliquer sur OK : 
 

 
 
Les données sont à présent affichées en live dans Microsoft Excel. Vous pouvez retravailler 
plus tard ces données dans Microsoft Excel. 
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6.2 Visualiser les données d’une ou de plusieurs tables avec l’assistant (wizard)  
 
Etape 1: Ouvrir Microsoft Excel 2003/2007 et créer une nouvelle feuille. 
 
Etape 2: Microsoft Excel 2003 

 
Sélectionner le menu Données > Import données externes > Créer une requête… 
Menu en anglais : Data > Import External Data > New Database Query… 
 

 
Microsoft Excel 2007 
 
Sélectionner le menu  Données > Import données externes > Créer une requête Data >  
Menu en anglais : Data > Import External Data > New Database Query… 
 

 
 
Etape 3: Sélectionner  <ABIDATA> et cliquer sur OK: 

 

 
 
Décocher l’option Use the Query wizard to create/edit queries. 
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Etape 4: Introduire l’ID et le mot de passe : 

 

 
 

 
Si vous n’avez pas d’accès, veuillez contrôler si : 

 L’ID et le mot de passe sont corrects. 

 L’utilisateur est relié à un profil externe. 

 Le lien ODBC travaille correctement. 

 SQL Server : contrôler si l’option « Use Trusted Connection » est décochée. 

 

Etape 5: Sélectionner à tout moment la table que vous souhaitez affichée et cliquer sur Ajouter : 
 

 

 

Après avoir sélectionné les tables nécessaires, cliquer sur Close (Fermer). 

 

Etape 6: Si vous utilisez plusieurs tables, il est important d’établir des relations entre elles. Dans la 
documentation de la structure d’une base de données, les relations  sont affichées dans les 
descriptions sous <(= nom du champ)>. 
 
Sélectionner les champs relationnels et créer la relation. Pour cela, glisser d’un champ vers 
l’autre :  
 

 

 

Etape 7: Cocher dans le menu Records l’option Automatic Query pour visualiser, chaque fois, les 
données après l’ajout d’un champ, d’un critère de recherche ou d’un tri. 
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Etape 8: Glisser les champs souhaités en dessous, vers la table. 

 

Etape 9: Déterminer, si vous le souhaitez, le critère de recherche via le menu Criteria > Add 
criteria. Ensuite, il vous est toujours possible de filtrer et de retravailler les données. 

 

Etape 10: Déterminer, si vous le souhaitez, le tri des données via le menu Record > Sort. 
Ensuite, il vous est toujours possible de modifier le tri les données  

 

Etape 11: Pour exécuter une requête (Automatic Query est coché), vous sélectionnez dans le menu       
Records, la ligne Query Now. 

 

Etape 12: Vous pouvez retravailler ensuite la requête créée et ensuite l’affichée si vous le désirez. 

 

Etape 13: Pour afficher les données dans Microsoft Excel, vous avez les possibilités suivantes : 

1. Sélectionner la ligne ou la colonne souhaitée, la copier et la coller ensuite dans Excel. 

2. Sélectionner le menu File > Return data to Microsoft Office Excel. Attention 
Microsoft Query se ferme sans que les données soient sauvegardées. 

 

Etape 14: Si vous affichez les données dans Microsoft Excel, vous pouvez déterminer dans quelle 
feuille elle sera placée. Détermine, si vous le souhaitez, une autre place et cliquer sur OK : 
 

  

Les données sont à présent affichées dans Microsoft Excel.  

Vous pouvez les retravailler dans Microsoft Excel. 

 

6.3 Remarques 
 

 

 
Pour plus d’information, veuillez vous référer au mode d’emploi de Microsoft Excel et 
plus précisément à Microsoft Query. 
 

 
Les données sont toujours affichées et restituées une seule fois dans Microsoft Excel. 
 
Les données affichées appartiennent à la feuille de Microsoft Excel et non d’AbiFire. 
 

 

 
Lors de la modification des données dans Excel, les données ne sont pas modifiées 
dans AbiFire. 
Lors de la modification des données dans AbiFire, les données ne sont pas modifiées 
dans Excel. 
 

 
Pour ensuite actualiser dans une feuille les données, sélectionner le menu Données> Rafraîchir les 
données.
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6. Microsoft Access 2003/2007 et ODBC 
 

 

 
 

 
Microsoft Access travaille sur base de “Machine Data sources”, appelé “Sources de 
données machine” et travaille toujours avec des données live. Aucune donnée n’est 
donc copiée vers Microsoft Access comme c’est le cas pour Microsoft Excel. 
 

 
Si une version active d’AbiFire5 ou AbiDispatch5 est installée sur votre PC, vous pouvez utiliser les 
données de connexion existantes. Celles-ci sont sauvegardées dans une source de données ODBC 
et permettent, en même temps, de lier des tables avec le fichier access (cfr. Paragraphe 5.2). 
 
Si tel n’est pas le cas, vous devez créer dans un premier temps, dans votre PC une nouvelle source 
de données ODBC. 
 
 

6.1 Visualiser des données  
 

Etape 1: Ouvrir Microsoft Access 2003/2007 et créer un nouveau fichier. 

 

Etape 2: Microsoft Access 2003 

 

Sélectionner le menu Données > Données externes > Lier des tables… 
Menu en anglais : File > Get External Data > Link Tables… 

 

Microsoft Excel 2007 

 

Sélectionner le menu Données > Données Externes > Plus >  Base de données ODBC... 
Menu en anglais : Data > External Data > More > ODBC Database… 
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Etape 3: La fenêtre de dialogue ODBC apparaît.  
Sélectionner l’onglet Machine Data Source et cliquer la source de données ABIDATA : 
 

 

 

Etape 4: Introduire l’ID et le mot de passe :  
 

 
 

 
Si vous n’avez pas d’accès, veuillez contrôler si : 

 L’ID et le mot de passe sont corrects. 

 L’utilisateur est relié à un profil externe. 

 Le lien ODBC travaille correctement. 

 SQL Server : contrôler si l’option « Use Trusted Connection » est décochée. 
 

Etape 5: Déterminer les tables que vous souhaitez afficher et cliquer sur OK : 

  

 

 

 

 

 

 

 

 

 

Pour quelques tables, Microsoft Access demandera une identification de l’enregistrement 
unique. Vous pouvez  ignorer et cliquer sur OK. 
 

Etape 6:  Vous pouvez à présent démarrer vos requêtes, rapports etc… 
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6.2 Remarques 
 

 

 
 

 
Pour plus d’information, veuillez vous référer au mode d’emploi de Microsoft Access. 
 

 
Microsoft Access travaille avec des données live : les tables de la base de données d’ABIDATA et 
votre fichier Access sont liées ensemble. 
 
Les données sont uniquement consultées dans Microsoft Access mais ne peuvent pas être 
retravaillées. 
 

 

 
 

 
Lors de la modification de données dans AbiFire, les données sont automatiquement 
actualisées dans Microsoft Access si la requête est à nouveau exécutée. 
 

 
 


